$re = '/\d+ (?:to|-) \d+ km/m';
$str = '3 to 6 km. 3 - 6 km';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);