package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ab{2,}`)
var str = `aaabcc
aaaabbcc
aabbbbc
aacc
a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}