package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\Bgngsn\B`)
var str = `aagngsnaa
gngsn
http://gngsn.tistory.com/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}