const regex = /\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s', 'gm')
const str = `더 캄캄한 이곳에 shine like the stars
그 미소를 띠며 I'll kiss you goodbye
실컷 비웃어라 꼴좋으니까
이제 너희 1 2 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}