re = /\D/m
str = '더 캄캄한 이곳에 shine like the stars
그 미소를 띠며 I\'ll kiss you goodbye
실컷 비웃어라 꼴좋으니까
이제 너희 1 2 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end