$re = '/^#([A-Fa-f0-9]{6}|[A-Fa-f0-9]{3})$/';
$str = '#223322';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);