package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\O`)
var str = `The 3oct lion roared`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}