import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Za-z]\\d ?\\d[A-Za-z]{2})|(?:[A-Za-z][A-Za-z\\d]\\d ?\\d[A-Za-z]{2})|(?:[A-Za-z]{2}\\d{2} ?\\d[A-Za-z]{2})|(?:[A-Za-z]\\d[A-Za-z] ?\\d[A-Za-z]{2})|(?:[A-Za-z]{2}\\d[A-Za-z] ?\\d[A-Za-z]{2})\n";
final String string = "EC1A 1BB\n"
+ "W1A 0AX\n"
+ "M1 1AE\n"
+ "B33 8TH\n"
+ "CR2 6XH\n"
+ "DN55 1PT\n"
+ "QN55 1PT\n"
+ "DI55 1PT\n"
+ "W1Z 0AX\n"
+ "EC1Z 1BB\n"
+ "DN55 1CT\n"
+ "A11A 1AA\n"
+ "AA11A 1AA\n"
+ "AA11 1AAA\n"
+ "AA11 1AAA\n"
+ "AAA 1AA\n"
+ "AA 1AA\n"
+ "A 1AA\n"
+ "1A 1AA\n"
+ "1 1AA\n"
+ "11 1AA\n"
+ "AA1 1A\n"
+ "AA1 1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}