$re = '/(?<!\S)(s|are|black|shoes|raju)(?!\S)/m';
$str = 'raju’s shoes are black';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);