package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z0-9!$%^&*()\-_=+]`)
var str = ` !"#$%&\'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_\`abcdefghijklmnopqrstuvwxyz{|}~`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}