$re = '/\b(9\d{3} ?\d{4} ?\d{4} ?\d{4} ?\d{4} ?\d{2} ?[a-z]{2} ?\d{3} ?\d{3} ?\d{3} ?US|9\d{3} ?\d{4} ?\d{4} ?\d{4} ?\d{4} ?\d{2})\b/mi';
$str = '9270 1000 0000 0000 0000 00 EA 000 000 000 US';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);