use strict;
my $str = '9270 1000 0000 0000 0000 00 EA 000 000 000 US';
my $regex = qr/\b9\d{3} ?\d{4} ?\d{4} ?\d{4} ?\d{4} ?\d{2}(?: ?[a-z]{2} ?\d{3} ?\d{3} ?\d{3} ?US)?\b/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}