re = /(?=.*0)(?=.*1)(?=.*2)(?=.*3)(?=.*4)(?=.*5)(?=.*6)(?=.*7)(?=.*8)(?=.*9)/m
str = '61243456092
864123456789
987601234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end