import re
regex = re.compile(r"^[A-Z]+(?:-[A-Z]+)*$", flags=re.MULTILINE)
test_str = ("PASS :\n"
"NOR\n"
"REGISTER\n"
"FLIP-FLOP\n"
"CPU\n"
"FLIP-FLOP-FLAP\n"
"A\n"
"A-A\n"
"ALL-GOOD\n"
"TIP-US-PLEASE\n"
"OR-IS-THERE-NO-WAY-TO-GET-STUDENT-RECOGNITION-FOR-DOMAINS\n\n"
"FAIL :\n"
"NO-TRAILING-DASH-\n"
"-ACTUALLY-NEITHER-WAY\n"
"NO-DIGIT-TEST1\n"
"2NO-DIGIT-TEST\n"
"N0-DIGIT-T3ST\n"
"NO-SPACE \n"
"NO-SPE_CIAL-CHAR\n"
"SURE?YES")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")