$re = '/[0-9]{1,2}(?:\.[0-9]{1,2})/';
$str = 'Puntuación de 4.5 estrellas';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);