import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\".*?(?<!\\\\)\"(*SKIP)(*F)| +";
final String string = "key1=value1 key1=value1 spaces=\"some spaces in text\" nested1=\"key2=value2 key2=value2 key2=value2\" nested2= \"key2=value2, key2=value2, key2=value2\" quoted=\"his name is \\\"no body\\\"\" something=else";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}