$re = '/^(?:\w+\/){2}\K\w+/';
$str = 'microsoft/netframework/docker/content/Y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);