$re = '/\(first\)(*SKIP)(*FAIL)|first/';
$str = 'This is a (first) test with the first hit';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);