# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<TextView(?:(?!fontFamily)[^>])*>"
test_str = ("<TextView\n"
" android:id=\"@+id/txt_refer_invite\"\n"
" android:layout_width=\"match_parent\"\n"
" android:layout_height=\"wrap_content\"\n"
" android:layout_below=\"@id/txt_refer_earn\"\n"
" android:layout_marginTop=\"8dp\"\n"
" android:fontFamily=\"@font/ms500\"\n"
" android:gravity=\"center\"\n"
" android:lineSpacingExtra=\"10sp\"\n"
" android:paddingLeft=\"16.7dp\"\n"
" android:paddingRight=\"16.7dp\"\n"
" android:text=\"@{data.description}\"\n"
" android:textColor=\"@color/color_858585\"\n"
" android:textSize=\"13.3sp\"/>\n"
"<TextView\n"
" android:id=\"@+id/txt_refer_code\"\n"
" android:layout_width=\"200dp\"\n"
" android:layout_height=\"48dp\"\n"
" android:layout_below=\"@id/txt_refer_invite\"\n"
" android:layout_centerHorizontal=\"true\"\n"
" android:layout_marginTop=\"22dp\"\n"
" android:background=\"@drawable/bg_refer_code\"\n"
" android:gravity=\"center\"\n"
" android:text=\"@{data==null?``:`Invite code : `+data.referralCode}\"\n"
" android:textColor=\"#9c9c9c\"\n"
" android:textSize=\"14.3sp\"/>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.