use strict;
my $str = '<TextView
android:id="@+id/txt_refer_invite"
android:layout_width="match_parent"
android:layout_height="wrap_content"
android:layout_below="@id/txt_refer_earn"
android:layout_marginTop="8dp"
android:fontFamily="@font/ms500"
android:gravity="center"
android:lineSpacingExtra="10sp"
android:paddingLeft="16.7dp"
android:paddingRight="16.7dp"
android:text="@{data.description}"
android:textColor="@color/color_858585"
android:textSize="13.3sp"/>
<TextView
android:id="@+id/txt_refer_code"
android:layout_width="200dp"
android:layout_height="48dp"
android:layout_below="@id/txt_refer_invite"
android:layout_centerHorizontal="true"
android:layout_marginTop="22dp"
android:background="@drawable/bg_refer_code"
android:gravity="center"
android:text="@{data==null?``:`Invite code : `+data.referralCode}"
android:textColor="#9c9c9c"
android:textSize="14.3sp"/>';
my $regex = qr/<TextView[^f>]*(?:f(?!ontFamily)[^f>]*)*>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}