re = /(?:\${)[a-zA-Z]+(?:})|(?:\${{)[a-zA-Z]+(?:}})|(?:{{)[a-zA-Z]+(?:}})/m
str = '${n},
{{coinsAdded}},
${coinsAdded},
{{sadfsa}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end