const regex = new RegExp('(?:(?:\\S+\\s+){0,2})?\\bmarble\\b\\S*(?:\\s+\\S+){0,2}', 'g')
const str = `Right. This marble is as slippery as this marble. Kwoo-oooo-waaa! Ahhhk!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}