#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?=(?:....)*$)"
Local $sString = "<html>" & @CRLF & _
"<head>" & @CRLF & _
"<title>Credit Card Test</title>" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
"<h1>Credit Card Test</h1>" & @CRLF & _
"" & @CRLF & _
"<form>" & @CRLF & _
"<p>Please enter your credit card number:</p>" & @CRLF & _
"" & @CRLF & _
"<p><input type="text" size="20" name="cardnumber"" & @CRLF & _
" onkeyup="validatecardnumber(this.value)"></p>" & @CRLF & _
"" & @CRLF & _
"<p id="notice">(no card number entered)</p>" & @CRLF & _
"</form>" & @CRLF & _
"" & @CRLF & _
"<script>" & @CRLF & _
"function validatecardnumber(cardnumber) {" & @CRLF & _
" // Strip spaces and dashes" & @CRLF & _
" cardnumber = cardnumber.replace(/[ -]/g, '');" & @CRLF & _
" // See if the card is valid" & @CRLF & _
" // The regex will capture the number in one of the capturing groups" & @CRLF & _
" var match = /^(?:(4[0-9]{12}(?:[0-9]{3})?)|(5[1-5][0-9]{14})|↵" & @CRLF & _
"(6(?:011|5[0-9]{2})[0-9]{12})|(3[47][0-9]{13})|(3(?:0[0-5]|[68][0-9])↵" & @CRLF & _
"[0-9]{11})|((?:2131|1800|35[0-9]{3})[0-9]{11}))$/.exec(cardnumber);" & @CRLF & _
" if (match) {" & @CRLF & _
" // List of card types, in the same order as the regex capturing groups" & @CRLF & _
" var types = ['Visa', 'MasterCard', 'Discover', 'American Express'," & @CRLF & _
" 'Diners Club', 'JCB'];" & @CRLF & _
" // Find the capturing group that matched" & @CRLF & _
" // Skip the zeroth element of the match array (the overall match)" & @CRLF & _
" for (var i = 1; i < match.length; i++) {" & @CRLF & _
" if (match[i]) {" & @CRLF & _
" // Display the card type for that group" & @CRLF & _
" document.getElementById('notice').innerHTML = types[i - 1];" & @CRLF & _
" break;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
" } else {" & @CRLF & _
" document.getElementById('notice').innerHTML = '(invalid card number)';" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"</script>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)