import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<protocol>[a-z\\-]+)?:?(?<slash>\\/\\/)?(?<host>[a-zA-Z0-9\\.]+)?(?P<port>:\\d+)?$";
final String string = "https://example.domain\n"
+ "http://example.domain\n"
+ "//example.domain\n"
+ "//example.com\n"
+ "https://example.com:34\n"
+ "//example.com:23\n"
+ "example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}