package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\t]*)\t+([^\t]*)\t+([^\t]*)\t+(.*)`)
var str = `03-24-2014 fm506 TOTAL-PROCESS OK;HARD;1;PROCS OK: 717 processes
03-24-2014 fm504 CHECK-LOAD OK;SOFT;2;OK - load average: 54.61, 56.95
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}