// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[highlight](.*?)\[\/highlight]").unwrap();
let string = "רמב״ם ספר המצוות שרשים ב׳
[[bשאין ראוי למנות כל מה שלמדים באחת משלש עשרה מדות שהתורה נדרשת בהן או מרבוי:[/b]
[א] כבר בארנו בפתיחת חבורנו בפירוש המשנה שרוב דיני התורה יצאו בשלש עשרה מדות שהתורה נדרשת בהם ושהדין היוצא במדה מאותן המדות הנה פעמים תפול בו המחלוקת ושיש שם דינין הן פירושים מקובלים ממשה אין מחלוקת בהם אבל הם מביאין ראיה עליהן באחת משלש עשרה מדות כי מחכמת הכתוב שהוא אפשר שימצא בו רמז מורה על הפירוש ההוא המקובל או היקש יורה עליו וכבר בארנו זה הענין שם.
וכשיהיה זה כן הנה לא כל מה שנמצא לחכמים שהוציאו בהיקש משלש עשרה מדות נאמר שהוא נאמר למשה בסיני ולא גם כן נאמר בכל מה שימצא בתלמוד שיסמכוהו אל אחת משלש עשרה מדות שהוא דרבנן, כי פעמים יהיה הפירוש ההוא מקובל ממשה בסיני לפי הראוי בזה שכל מה שלא תמצאהו כתוב בתורה ותמצאהו בתלמוד שלמדוהו באחת משלש עשרה מדות אם בארו הם בעצמם ואמרו שזה גוף תורה או שזה דאורייתא הנה ראוי למנותו אחר שהמקובלים ממנו אמרו שהוא דאורייתא.
[b]לא נתאוו החכמים והנביאים ימות המשיח, לא כדי שישלטו על כל העולם, ולא כדי שירדו בעכו\"ם, ולא כדי שינשאו אותם העמים, ולא כדי לאכול ולשתות ולשמוח, [/b][highlight][b]אלא כדי שיהיו פנויין בתורה וחכמתה[/b][/highlight][b], ולא יהיה להם נוגש ומבטל,[/b][highlight][b] כדי שיזכו לחיי העולם הבא, כמו שביארנו בהלכות תשובה. [/b][/highlight]
בבאור והוא אמרו יתברך ״ואהבת לרעך כמוך״ (ויקרא י״ט:י״ח), ובזה הדרך בעצמו מנו חשוב תקופות מצוה בעבור הדרש הבא ב ״היא חכמתכם ובינתכם״ (דברים ד׳:ו׳) והוא אמרם (בבלי שבת ע״ה.) איזו היא חכמה ובינה שהיא לעיני העמים הוי אומר זה חשוב תקופות ומזלות, ואילו מנה מה שהוא יותר מבואר מזה ויחשוב מה שהוא יותר.
ראוי למנותו והוא כל דבר שנלמד בתורה במדה משלש עשרה מדות שהתורה נדרשת בהן היה עולה מנין המצות לאלפים רבים.
ואולי תחשוב שאני בורח מלמנותן להיותן בלתי אמתיות והיות הדין היוצא במדה ההיא אמת או בלתי אמת, אין זו הסבה.
אבל הסבה כי כל מה שיוציא אדם ענפים מן השרשים שנאמרו לו למשה בסיני בבאור והם תרי״ג מצות ואפילו היה המוציא משה בעצמו אין ראוי למנותם.
והראיה על זה כלו אמרם בגמרא תמורה (בבלי תמורה דף ט״ז.) אלף ושבע מאות קלין וחמורין וגזירות שוות ודקדוקי סופרים שנשתכחו בימי אבלו של משה ואעפ״כ החזירן עתניאל בן קנז מפלפולו שנאמר ״כל איש אשר יכה את קרית ספר ולכדה״ וגו׳ (יהושע ט״ו:ט״ז) ״וילכדה עתניאל בן קנז״ (יהושע ט״ו:י״ז).
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}