#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<reducer>\w+)\(\)\s+of\s+query\((?P<dashboardUID>\w+)\/(?P<panelID>\d+)\/(?P<metric>.+),\s+(?P<from>\w+),\s+(?P<to>\w+)\)\s+is\s+(?P<evaluator>\w+)\((?P<params>-*\d*[\.,\s]*\d*)\)\s*(for\s+\((?P<for>\w+)\))*\s*(every\((?P<every>\w+)\))*\s*$"
Local $sString = "avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is below(14)" & @CRLF & _
"avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is below(0.4)" & @CRLF & _
"avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is novalue()" & @CRLF & _
"avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is withinrange(4, 88)" & @CRLF & _
"avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is withinrange(4, 88) for (1m)" & @CRLF & _
"avg() of query(wpFnYRwGk/2/bitrate, 15m, now) is withinrange(4, 88) for (1m) every(1m)" & @CRLF & _
"avg() of query(summary/152/tx-avg, 1m, now) is below(5000)" & @CRLF & _
"avg() of query(summary/152/tx-avg, 1m, now) is below(-5000)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")