$re = '/^(?:Not Specified|[^\r\n\d-]*-[^\r\n\d]*)$/m';
$str = '--
Not Specified
- - - eV
-270 - 1000 deg C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);