#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[nN]euer [Ff]ilm\s*(.*?)(?:\s*[vV]on\s+(\d{4}))?(?:\s+[Mm]it\s*(.*?)(?:\s*[uU]nd\s*(.*))?)?$"
Local $sString = "Neuer Film a von 1000" & @CRLF & _
"Neuer Film a von 1000 mit b" & @CRLF & _
"Neuer Film a von 1000 mit b und c" & @CRLF & _
"Neuer Film a von 1000 mit b und c und d" & @CRLF & _
"Neuer Film a mit b" & @CRLF & _
"Neuer Film a mit b und c" & @CRLF & _
"Neuer Film a mit b und c und d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")