re = /(?:3d|4d)-([\d\.-]+)!/m
str = 'Torre+Eiffel!8m2!3d-48.8583701!4d-2.2944813!3m4!1s0x47e66e2964e34e2d:0x8ddca9ee380ef7e0!8m2!3d-48.8583701!4d-2.2944813'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end