re = /\s(?<subdomain>\S+)(\.\S+){2}\b/m
str = 'this is a test: sub.domain.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end