#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<! {5})(\".+?\": [^\\[{\n]+(?:,|\n))|(?<! {5})(".+?": {[\S\s]+?},)|(?<! {5})(".+?": \[[\S\s]+?\],)"
Local $sString = "{" & @CRLF & _
" "applicationId": "id651979466"," & @CRLF & _
" "lastestVersion": "19.10.03"," & @CRLF & _
" "originalUrlBottomTitle": "Nguồn <publisherName>"," & @CRLF & _
" "titleUpdate": "Bạn đã sử dụng phiên bản cũ!!!"," & @CRLF & _
" "messageUpdate": "Hãy cập nhật ứng dụng để trải nghiệm các tính năng mới, hấp dẫn."," & @CRLF & _
" "linkUpdate": "https://itunes.apple.com/app/id651979466"," & @CRLF & _
" "introduce": {" & @CRLF & _
" "title": "Đối tác chính thức"," & @CRLF & _
" "introduceURL": "https://app.baomoi.com/publisher/list"" & @CRLF & _
" }," & @CRLF & _
" "buttonYes": "Cập nhật"," & @CRLF & _
" "buttonNo": "Để sau"," & @CRLF & _
" "statusUpdate": 0," & @CRLF & _
" "enableParse": true," & @CRLF & _
" "enableCrashlytics": true," & @CRLF & _
" "livescoreUrl": "https://baomoi.com/soccer/app"," & @CRLF & _
" "commentCollapseMin": 7," & @CRLF & _
" "shareZalo": true," & @CRLF & _
" "loginFacebook": false," & @CRLF & _
" "shareFacebook": true," & @CRLF & _
" "shareFacebookMess": true," & @CRLF & _
" "zal": true," & @CRLF & _
" "zalInterval": 259200," & @CRLF & _
" "userLoZalInterval": 86400," & @CRLF & _
" "show_comment_time_limit": 86400," & @CRLF & _
" "enableWebm": true," & @CRLF & _
" "enableRenderAvatarUserName": true," & @CRLF & _
" "avatarDefaultNames": [" & @CRLF & _
" "default"" & @CRLF & _
" ]," & @CRLF & _
" "logArticles": 3," & @CRLF & _
" "logVideos": 2," & @CRLF & _
" "show_feed_article_des": false," & @CRLF & _
" "inapp_noti_default_headline": "Báo Mới"," & @CRLF & _
" "QoSLogReqLimit": 50," & @CRLF & _
" "QoSLogTimeLimit": 0," & @CRLF & _
" "QoSLogTimeLimitImages": 0," & @CRLF & _
" "impsLogTime": 1000," & @CRLF & _
" "impsLogSize": 20," & @CRLF & _
" "impsPollLogSize": 1," & @CRLF & _
" "timeReloadAds": 5," & @CRLF & _
" "defaultMode": 0," & @CRLF & _
" "defaultModeTablet": 0," & @CRLF & _
" "defaultModeIP5": 1," & @CRLF & _
" "maxArticles": 1000," & @CRLF & _
" "maxVideos": 200," & @CRLF & _
" "maxHotComments": 3," & @CRLF & _
" "timeReloadApp": 1800," & @CRLF & _
" "smallPreset": "a300,w200_r4x3,a400x"," & @CRLF & _
" "mediumPreset": "a400,w200_r4x3,a500x"," & @CRLF & _
" "largePreset": "a500,w300_r4x3,a700x"," & @CRLF & _
" "iPadPreset": "a700,w400_r4x3,a800x"," & @CRLF & _
" "iPX_listArticleFontSize": "18,20,22"," & @CRLF & _
" "iPX_feedArticleFontSize": "18,20,22"," & @CRLF & _
" "iPX_listTitleFontSize": 17," & @CRLF & _
" "iPX_feedTitleFontSize": 19," & @CRLF & _
" "iP6_listArticleFontSize": "18,20,22"," & @CRLF & _
" "iP6_feedArticleFontSize": "18,20,22"," & @CRLF & _
" "iP6_listTitleFontSize": 18," & @CRLF & _
" "iP6_feedTitleFontSize": 20," & @CRLF & _
" "iP6P_listArticleFontSize": "18,20,22"," & @CRLF & _
" "iP6P_feedArticleFontSize": "18,20,22"," & @CRLF & _
" "iP6P_listTitleFontSize": 18," & @CRLF & _
" "iP6P_feedTitleFontSize": 20," & @CRLF & _
" "iPad_listArticleFontSize": "22,24,26"," & @CRLF & _
" "iPad_feedArticleFontSize": "24,26,28"," & @CRLF & _
" "iPad_listTitleFontSize": 24," & @CRLF & _
" "iPad_feedTitleFontSize": 26," & @CRLF & _
" "iP5_listArticleFontSize": "18,20,22"," & @CRLF & _
" "iP5_feedArticleFontSize": "20,22,24"," & @CRLF & _
" "iP5_listTitleFontSize": 18," & @CRLF & _
" "iP5_feedTitleFontSize": 22," & @CRLF & _
" "pageRequestCounter": 15," & @CRLF & _
" "showCounter": true," & @CRLF & _
" "showLastestNewsButton": true," & @CRLF & _
" "showSlideBanner": false," & @CRLF & _
" "videoFormat": 0," & @CRLF & _
" "allowPreloadVideo": true," & @CRLF & _
" "wifi_chunkPreloadVideo": 1," & @CRLF & _
" "3g_chunkPreloadVideo": 0," & @CRLF & _
" "commentHints": "Bình luận phải có ít nhất 3 chữ|Bình luận phải dùng tiếng Việt có dấu.|Bình luận không nói tục, chửi bậy.|Bình luận không chứa liên kết, quảng cáo."," & @CRLF & _
" "feedName": "Theo dõi"," & @CRLF & _
" "feedThumbURL": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/AppFeedThumb/feedthumb1.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/AppFeedThumb/feedthumb2.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/AppFeedThumb/feedthumb3.jpg"" & @CRLF & _
" ]," & @CRLF & _
" "feedEmptyScreenMsg": "Theo dõi thêm nguồn \nđể có thêm tin trong danh sách"," & @CRLF & _
" "defaultZoneNewsTab": "c_0"," & @CRLF & _
" "fixedZones": "Tin nóng|c_0,Tin mới|c_-1"," & @CRLF & _
" "defaultZones": "Bóng đá VN|c_87,Bóng đá QT|c_86,Độc & Lạ|c_79,Tình yêu|c_139,Giải trí|c_52,Thế giới|c_119,Pháp luật|c_58,Xe 360|c_145,Công Nghệ|c_53,Ẩm thực|c_84,Làm đẹp|c_138,Sức khỏe|c_82,Du lịch|c_137"," & @CRLF & _
" "allZones": "Tin mới|c_-1,Bóng đá VN|c_87,Bóng đá QT|c_86,Độc & Lạ|c_79,Tình yêu|c_139,Giải trí|c_52,Thế giới|c_119,Pháp luật|c_58,Xe 360|c_145,Công Nghệ|c_53,Ẩm thực|c_84,Làm đẹp|c_138,Sức khỏe|c_82,Du lịch|c_137,Nhà đất|c_147,Thời sự|c_144,Thiết bị - Phần cứng|c_136,Kinh tế|c_45,Giáo dục|c_59,Không gian - Kiến trúc|c_150,Thời trang|c_72"," & @CRLF & _
" "updatedZones": "Bóng đá VN|c_87"," & @CRLF & _
" "excludedZones": ""," & @CRLF & _
" "changedZones": "k_Biển Đông|top_228,st_5|top_228"," & @CRLF & _
" "regions": "Hà Nội|r_Hà Nội|29,TP. HCM|r_TP. HCM|50,An Giang|r_An Giang|67,Bắc Giang|r_Bắc Giang|98,Bắc Kạn|r_Bắc Kạn|97,Bạc Liêu|r_Bạc Liêu|94,Bắc Ninh|r_Bắc Ninh|99,Bến Tre|r_Bến Tre|71,Bình Định|r_Bình Định|77,Bình Dương|r_Bình Dương|61,Bình Phước|r_Bình Phước|93,Bình Thuận|r_Bình Thuận|86,BR-VT|r_BR-VT|72,Cà Mau|r_Cà Mau|69,Cần Thơ|r_Cần Thơ|65,Cao Bằng|r_Cao Bằng|11,Đà Nẵng|r_Đà Nẵng|43,Đăk Lăk|r_Đăk Lăk|47,Đăk Nông|r_Đăk Nông|48,Điện Biên|r_Điện Biên|27,Đồng Nai|r_Đồng Nai|60,Đồng Tháp|r_Đồng Tháp|66,Gia Lai|r_Gia Lai|81,Hà Giang|r_Hà Giang|23,Hà Nam|r_Hà Nam|90,Hà Tĩnh|r_Hà Tĩnh|38,Hải Dương|r_Hải Dương|34,Hải Phòng|r_Hải Phòng|15,Hậu Giang|r_Hậu Giang|95,Hòa Bình|r_Hòa Bình|28,Hưng Yên|r_Hưng Yên|89,Khánh Hòa|r_Khánh Hòa|79,Kiên Giang|r_Kiên Giang|68,Kon Tum|r_Kon Tum|82,Lai Châu|r_Lai Châu|25,Lâm Đồng|r_Lâm Đồng|49,Lạng Sơn|r_Lạng Sơn|12,Lào Cai|r_Lào Cai|24,Long An|r_Long An|62,Nam Định|r_Nam Định|18,Nghệ An|r_Nghệ An|37,Ninh Bình|r_Ninh Bình|35,Ninh Thuận|r_Ninh Thuận|85,Phú Thọ|r_Phú Thọ|19,Phú Yên|r_Phú Yên|78,Quảng Bình|r_Quảng Bình|73,Quảng Nam|r_Quảng Nam|92,Quảng Ngãi|r_Quảng Ngãi|76,Quảng Ninh|r_Quảng Ninh|14,Quảng Trị|r_Quảng Trị|74,Sóc Trăng|r_Sóc Trăng|83,Sơn La|r_Sơn La|26,Tây Ninh|r_Tây Ninh|70,Thái Bình|r_Thái Bình|17,Thái Nguyên|r_Thái Nguyên|20,Thanh Hóa|r_Thanh Hóa|36,Tiền Giang|r_Tiền Giang|63,Trà Vinh|r_Trà Vinh|84,TT Huế|r_TT Huế|75,Tuyên Quang|r_Tuyên Quang|22,Vĩnh Long|r_Vĩnh Long|64,Vĩnh Phúc|r_Vĩnh Phúc|88,Yên Bái|r_Yên Bái|21"," & @CRLF & _
" "domainIcon": "https://baomoi-static.zadn.vn/icon_publishers"," & @CRLF & _
" "topPublishers": "VietnamNet|p_23,Tiền Phong|p_20,VTC News|p_83,Zing|p_119,VOV|p_65,VietnamPlus|p_293,PLO|p_114,Infonet|p_240"," & @CRLF & _
" "defaultVideoZones": [" & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Mới"," & @CRLF & _
" "zoneId": "v_-1"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/New/v_-1_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/New/v_-1_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/New/v_-1_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Ahihi"," & @CRLF & _
" "zoneId": "v_12"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Ahihi/v_12_1_20181031_fixed.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Ahihi/v_12_2_20181031_fixed.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Ahihi/v_12_3_20181031_fixed.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "OMG"," & @CRLF & _
" "zoneId": "v_47"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/OMG/v_47_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/OMG/v_47_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/OMG/v_47_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "2Tek"," & @CRLF & _
" "zoneId": "v_43"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Hightek/v_43_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Hightek/v_43_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Hightek/v_43_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Bóng đá"," & @CRLF & _
" "zoneId": "v_21"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/BongDa/v_21_1_20181108.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/BongDa/v_21_2_20181108.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/BongDa/v_21_3_20181108.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Cute"," & @CRLF & _
" "zoneId": "v_40"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Cute/v_40_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Cute/v_40_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Cute/v_40_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Showbiz"," & @CRLF & _
" "zoneId": "v_6"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Showbiz/v_6_1_20181226.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Showbiz/v_6_2_20181226.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Showbiz/v_6_3_20181226.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Sống"," & @CRLF & _
" "zoneId": "v_37"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Ngam/v_37_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Ngam/v_37_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Ngam/v_37_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Lifestyle"," & @CRLF & _
" "zoneId": "v_16"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/LifeStyle/v_16_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/LifeStyle/v_16_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/LifeStyle/v_16_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "News"," & @CRLF & _
" "zoneId": "v_1"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/News/v_1_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/News/v_1_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/News/v_1_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "zoneName": "Top"," & @CRLF & _
" "zoneId": "v_0"," & @CRLF & _
" "images": [" & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Top/v_0_1_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Top/v_0_2_20181031.jpg"," & @CRLF & _
" "https://baomoi-static.zadn.vn/Uploaded/VideoSubTabImgs/Top/v_0_3_20181031.jpg"" & @CRLF & _
" ]" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "pubProfileTabsName": "1|Tổng hợp,9|Video,13|Poll,15|Q&A"," & @CRLF & _
" "logChannels": 2," & @CRLF & _
" "maxChannelContents": 10," & @CRLF & _
" "channelFontSize": "13,14,14"," & @CRLF & _
" "articleVideoMode": 1," & @CRLF & _
" "articleViewMode": 1," & @CRLF & _
" "tapForSoundShowingTime": 1," & @CRLF & _
" "tapForSoundText": "Bấm video để mở tiếng"," & @CRLF & _
" "numberOfInsertedArticles": 3," & @CRLF & _
" "recommendListRefreshInterval": 1800000," & @CRLF & _
" "showRecommendGroup": false," & @CRLF & _
" "recommendGroupName": "CÓ THỂ BẠN QUAN TÂM"," & @CRLF & _
" "recommendGroupBtnText": "Xem thêm"," & @CRLF & _
" "suggestReplyCondition": 3," & @CRLF & _
" "hideArticleReasonsDefault": "Bạo lực|content,Đồi trụy|content,Phản cảm|content,Xuyên tạc|content,Kỳ thị địa phương|content"," & @CRLF & _
" "popupHideArticleMsg": "Vui lòng chọn các nguyên nhân khiến bạn không thích bài viết này để chúng tôi có thể đề xuất tin cho bạn tốt hơn"," & @CRLF & _
" "reportArticleReasons": "Tin gốc đã gỡ|original_removed,Tin gốc đã cập nhật|original_updated,Bạo lực|content,Đồi trụy|content,Phản cảm|content,Xuyên tạc|content,Kỳ thị địa phương|content,Ý kiến khác...|other"," & @CRLF & _
" "popupReportArticleMsg": "Vui lòng chọn các nguyên nhân bạn muốn báo cáo nội dung bài viết này"," & @CRLF & _
" "reportVideoReasons": "Tin gốc đã gỡ|original_removed,Tin gốc đã cập nhật|original_updated,Bạo lực|content,Đồi trụy|content,Phản cảm|content,Xuyên tạc|content,Kỳ thị địa phương|content,Ý kiến khác...|other"," & @CRLF & _
" "popupReportVideoMsg": "Vui lòng chọn các nguyên nhân bạn muốn báo cáo nội dung video này"," & @CRLF & _
" "reportCommentReasons": "Bạo lực|comment,Đồi trụy|comment,Phản cảm|comment,Xuyên tạc|comment,Kỳ thị địa phương|comment,Spam|comment,Ý kiến khác...|other"," & @CRLF & _
" "popupReportCommentMsg": "Vui lòng chọn các nguyên nhân báo xấu bình luận này của người dùng %s"," & @CRLF & _
" "stepToShowTripleCell": 0," & @CRLF & _
" "appNavBarBg": "https://baomoi-static.zadn.vn/Uploaded/Bao_BD/nav_bar_bg_default@3x.png"," & @CRLF & _
" "nativeAdsReportMessage": "Chúng tôi sẽ cố gắng hạn chế hiển thị quảng cáo này đến bạn."," & @CRLF & _
" "nativeAdsReportPopupMsg": "Vui lòng chọn các nguyên nhân báo xấu quảng cáo này"," & @CRLF & _
" "articleVideoAutoPlay": true," & @CRLF & _
" "listVideoAutoPlay": true," & @CRLF & _
" "listVideoAutoPlayNext": true," & @CRLF & _
" "listTopCmtArticleCondition": "50,200,500"," & @CRLF & _
" "replyLoadMoreAmount": 10," & @CRLF & _
" "articleTopCommentGroup": true," & @CRLF & _
" "coverageEnable": true," & @CRLF & _
" "articleCmtBoxHiddenEnable": true," & @CRLF & _
" "articleViewCloseBtnCondition": 2," & @CRLF & _
" "sectionBoxesEnable": [" & @CRLF & _
" 0," & @CRLF & _
" 1," & @CRLF & _
" 2," & @CRLF & _
" 3," & @CRLF & _
" 4," & @CRLF & _
" 10," & @CRLF & _
" 11," & @CRLF & _
" 20," & @CRLF & _
" 30," & @CRLF & _
" 40" & @CRLF & _
" ]," & @CRLF & _
" "content_type": {" & @CRLF & _
" "article": [" & @CRLF & _
" 1" & @CRLF & _
" ]," & @CRLF & _
" "video": [" & @CRLF & _
" 9" & @CRLF & _
" ]," & @CRLF & _
" "topic": [" & @CRLF & _
" 5," & @CRLF & _
" 6," & @CRLF & _
" 7" & @CRLF & _
" ]," & @CRLF & _
" "qaQuestion": [" & @CRLF & _
" 15" & @CRLF & _
" ]," & @CRLF & _
" "qaAnswer": [" & @CRLF & _
" 16" & @CRLF & _
" ]," & @CRLF & _
" "poll": [" & @CRLF & _
" 13" & @CRLF & _
" ]," & @CRLF & _
" "comment": [" & @CRLF & _
" 18" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" "qaHistorySize": 40" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")