import re
regex = re.compile(r"^(mm[gvis]([0-9]{1,3})?|((media(\.|-)[a-zA-Z]{1,4}[0-9]{1,2}-[0-9]{1,2}\.)(cdn|fna)))\.whatsapp\.net$", flags=re.MULTILINE)
test_str = ("mms241.whatsapp.net\n"
"mmi362.whatsapp.net\n"
"mmv785.whatsapp.net\n"
"mmg362.whatsapp.net\n"
"mmg.whatsapp.net\n"
"media.fada1-1.fna.whatsapp.net\n"
"media.faq12-1.fna.whatsapp.net\n"
"media.saq1-13.fna.whatsapp.net\n"
"media.sif1-2.cdn.whatsapp.net\n"
"media.scf21-2.cdn.whatsapp.net\n"
"media.sqf1-25.cdn.whatsapp.net\n"
"media-scf21-2.cdn.whatsapp.net\n"
"media-sqf1-25.cdn.whatsapp.net\n"
"media-fawq1-13.fna.whatsapp.net\n"
"media.fyei6-5.fna.whatsapp.net")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")