import re
regex = re.compile(r"\[[0-5][0-9]:[0-5][0-9]]\s*(.+?\s+-\s+.+)", flags=re.MULTILINE)
test_str = ("Text text text\n\n"
"Tracklist:\n"
"[00:00] Sobs - Girl\n"
"[02:25] Mopac - Cross-Eyed Dreaming\n"
"[05:54] L I P S - In Summer\n"
"[09:18] Small Wood House - T.V\n\n"
"Text text text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")