// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\([^+]*\)|\(\d+\+\d+\)").unwrap();
let string = "[-4,1]+[-7,1]*([3,5]-([-1,2]*[4,5]-[0,2]))+(3+4)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}