$re = '/^[A-Z]{1}[a-zA-Z]+_[A-Z]{1}[a-zA-Z]+$/m';
$str = 'Test_Test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);