package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?P<text_loading>(Loading last campaign ID)|(Loading campaign with ID))|(?P<text_creating>Creating new campaign with ID))\s*(?P<campaign_id>\d+)`)
var str = `2022/07/04, 06:11:28 2022-07-04 13:11:28:248 | Antistasi | Info | File: A3A_fnc_initServer | Loading last campaign ID 93344
2022/07/03, 11:16:29 2022-07-03 18:16:29:031 | Antistasi | Info | File: A3A_fnc_initServer | Creating new campaign with ID 28899
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}