re = /^(\((?:[^()]|\1*)\)[^()]*)+$/m
str = '(1+2)*(2+5)
(1+2(3+4)-6)/(2+4)
((()))
(3+4()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end