$re = '/(?<=\b|[a-z]|)(ShFrm|LgFrm|Auto)(?=[A-Z]|\b)/m';
$str = 'ShFrm
LgFrm
Auto';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);