$re = '/(c:\\\\program files \(x86\)\\\\microsoft visual studio\\\\\d{4}\\\\enterprise\\\\msbuild\\\\\d{2}\.\d{1}\\\\bin)/mi';
$str = 'C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Enterprise\\MSBuild\\15.0\\Bin\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);