$re = '/(?<!\S)\S+:\s*\S*[^:\s](?!\S)/m';
$str = 'Lorem ipsum age:85 date:15.05.2015 sender: user: John Doe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);