$re = '/^(?:[A-Z0-9]{1,3}(?:, ?))*[A-Z0-9]{1,3}$/m';
$str = 'BRUALC
BRU ALC
BRU,ALC
BRU, ALC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);