re = /^now\(\)([+|-][0-9]+(y|mon|d|h|m|s))*(@(y|mon|d|h|m|s))?/m
str = 'now()+3d@y'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end