re = /\b(?!(?:WHOLE|GARDENER)\b)\w*(?:BUNNY|GARDEN|HOLE)\w*\b/i
str = 'This whole hole is a wholey mistake in the gardener agardener.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end