package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^AB[a-zA-Z]?\d*\s`)
var str = `husdfg e AB HUT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}