$re = '/^{start}(.*){end}$/m';
$str = '{start} SubPattern1 {end}
....
{start} SubPattern2 {end}
....
{start} {start}SubPattern3{end} {end}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);