package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(hello)`)
var str = `hello world hello person`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}