re = /(?<=\bchild )(?:(?! child).)+/mi
str = 'child mick jagger child john wayne child archimedes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end