const regex = /(?s)\R\K\[\[(.*?)\R*]](?=\R)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\R\\K\\[\\[(.*?)\\R*]](?=\\R)', 'gm')
const str = `Másutt bővebben, másképp megírva:
A család szükségszerűen áll apából, anyából és gyerek(ek)ből. Hogy a gyerek [[mag]] = Nap, erről másutt volt szó (még a keltában is mag, mac = fiú) illetve arról is, hogy a fiú régen gyerek, sarj értelmű volt. Viszont a csillagmitológiában a lány az anya fiatalabb énjére utal (lásd [[daughter]] és [[tündér]]), míg a fiú az anya fia, Napgyermeke, kiből felnővén (amikor a Nap a Szíriusszal, Orionnal együtt áll és Hunor-Széth lesz belőle) a szerelmese is lesz ([[incest]] címnél erről volt szó; ezen a ponton ölheti meg apját, Oriont a Nap, hogy anyját nőül vegye), ami alatt azt kell érteni, hogy a Nap a Tejút körén mozog, semmi mást (anya nem hálhat fiánal a valóságban). A [[Nap]] címnél, *Nap és Orion* alcímnél álló Nap = Orionná válás így érthető meg.
De ki is az az [[Orion]]? Nevének értelmezése szerint az Ég Ura. [[Anu]] címnél is volt arról szó ([[isten]] címnél is, ahol sok másról is szó volt), hogy hogyan alakulhatott ki hímségiként kezelése. Azóta legutóbb [[Ninsubur]] címnél írottak alapján pontosítunk:
[[Ninsubur]] neve úgy jött elő [[Papsukkal]] címnél, minthogy állítólag az Orion alakja nőiség lett volna? Aligha. Nyilván félreértésről van szó. Orion nem lehet nőiség, ahogy a Nap sem (nincs olyan, hogy [[Napistennő]]). A félrértést az okozza, hogy Orion (Úr-Isten) mellett ott van az Istenanya (An, Ana, Anu; [[Szíriusz mint istenanya]]), el nem választhatóan.
[[Isa]] címnél is, sémi és szanszkrit szavak által bemutatásra került, hogy az Úr(isten) és a neje lehet Orion és Szíriusz.
Tehát egyrészt Orion és Szíriusz egymástól el nem választhatósága adja meg a választ, másrészt az, hogy maga [[Szíriusz]] is kettős [[androgün]]: egyszerre nőiségi és hímségi természetű (hisz ott zajlik a nemzés). Orion az Ég Ura (Uri-An, Uru-An; az An, Án = ég jelentése eredetileg az éj sötétjére, a tágabban értelmezhető istenanyára utal), míg Szíriusz az Anya ([[Szíriusz mint istenanya]]) (viszont [[HágárAgar]] és [[Akar]] olvasata szerint szintén Ég Úr értelmű: [[Hágár]] és nemzője [[Ábrahám]] egyek Szíriuszban és Orionban).
[[Orion]] címnél írtuk legutóbb:
Nem tartom elképzelhetetlennek, hogy a nemcsak akkád, hanem sumér nyelvűként is helyes Uru-Anna tulajdonképpen (mondjuk ki: magyarítva) Uru-Anya, azaz az Anyaistenennő Ura, azaz Férje értelmű is lehet, magyar istencsalád, azaz itt ezen címnél írottak alapján.
De egyre több helyen (épp itt fentebb is) kimondtuk már azt is, hogy a viszonyrendszer értelmében az Orion neve vítethet át Tejút-elnevezésre is.
Pető Imre Hun nyelvi tanulmányok c. könyvében amikor (az örmény forrásokból dolgozó) Detre Csaba adata alapján Orionnak Würen nevét adja meg, GYÁ-val egyetértően írja:
Würen - Orion. Talán valamiféle- //M -őr, eredetileg valószínűleg, würeni fényjelző őr (D. Cs.) A Würen hangtani és jelentésbeli azonossága az Orionnal nyilvánvaló. Nimród Ősapánk égi tisztében valóban fényőrként szolgál. Karjánál a Bethelgeuze, lábszára a Zarugh ("záró"). A magyar történelmi mitológia tükröződik vissza a csillagok neveiben is. Híres csillagának, a Bethelgeuzének Kárpát-medencei neve: Óriásgázlója. A Würen Mezopotámiában Nimrud, a Biblia és a magyar krónikák Óriása, a magyarság mítoszi Ősapja. Az ő fiai Hunor, Magor, és némely krónika szerint - Bor. Nincs magányban. Felesége a csillagmezőn segíti őt: Meme, Memazdigh. Feleség, hunul: eme, meme. Mezopotámiai neve: EME.
Megjegyzés: a feleség értelem asszony és nő (honnan is: nej, nejem) alapértelemből indul ki.
[[Eme]] Dr. Gyárfás Ágnesnél is az istenanya (= Inanna, Szíriusz) neve=={4}==, melynek alhangi párja, [[Ama]] például [[Sarama]] nevében is megvan.
[[Kazár]] címnél, *Kazár - Pater* alcímnél is írtuk, hogy a [[Tejútanya]] (kinek [[egy csillagba centralizált önmaga Szíriusz]]) ura/férje Orion:[[
Pater]]-ről megállapítottuk, hogy nemcsak hogy Égatya (honnan a földi apákra átszálló jelentése is) értelmű, hanem Orionnak felel meg. Ahogy [[Kazár]] is. Tulajdonképpen azonos jelentésűek is: a Ház Ura. A [[Ház]] a Tejútanya, akinek ura (férje) Orion.
[[Szép]] címnél, *szép apa és szép anya* alcímnél is utaltunk a Szíriusszal azonos Anya és a Nimrud-Orionnal azonos Apa ősi-szép szerepkörére.
[[Ló]] címnél, *ló az égen* alcímnél és *ló anya életfás növényesedéssel és párduc apa* al-alcímnél két övcsaton ősvallásunkból ismert Tejútanya+Nimrud ábrázolást látunk, mely ismét bizonyítja, hogy a párduc-panther Nimrud-Orion és hogy a Fehérlófia anyja, a Tejút egy pár.
[[A férj és feleség, Orion és Szíriusz összetartozósága
]]
Nagyon sok helyen, főleg [[Íj csillagkép]], [[Orion övcsillagai]], [[kovács és a kutya]] és sok más helyen szó esett arról, hogy ezek összetartoznak. [[Khuda]] és [[God]] címnél még ez is elhangzott az iráni Khuda kapcsán:`;
const subst = `## $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);