const regex = /\b(?!\d{2}[A-Z]{3}1\d)(?=[A-Z\d]*\d\b)[A-Z\d-]{6,}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!\\d{2}[A-Z]{3}1\\d)(?=[A-Z\\d]*\\d\\b)[A-Z\\d-]{6,}\\b', 'g')
const str = `HOSTON HOHOHJGH HGOGHH 129387129387 17MAR19`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}